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1 Overview

2dTiler is an interactive viewer for periodic tilings of all three two-dimensional geometries,
written by Daniel Huson and Klaus Westphal. Input is a �le of records, each describing a
Delaney-Dresssymbol, a data-structure that prescribes the topology and symmetries of a peri-
odic tiling , and output is the picture of that tiling. The geometric shape of the tiles and the
speci�c symmetry group can be interactively modi�ed.

2 Installation

To install the program under Linux, download the archive �le
http://www- ab.informatik. uni- tueb ing en.d e/so ftw are/ 2dti ler /2dt iler 20. zip and
unpack it using the command unzip 2dtiler20.zip .

this will produce a directory 2dtiler containing the following:

� a �le manual.pdf containing a user manual for the program,

� a script 2dt to start the program from outside of the 2dtiler directory,

� the executableprogram 2dt.exe ,

� a directory lib containing a compiled version of TCL-TK(8.0.5), and

� a directory tilings containing a number of input �les for the program.

To start the program, cd 2dtiler and then type 2dt.exe . If you would like to be able to start the
program from outside of the 2dtiler directory, then pleaseset an enviroment variable TILERDIR
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to point at the directory, e.g. setenv TILERDIR ~/2dtiler , and then copy the �le 2dtiler/2dt
to your bin directory. Then you can use2dt to start the program.

Imp ortan t: The program requires TCL-TK version 8.0.5. (Precisely this version, not an ear-
lier or later one!). A compiled version of this is provided with the program, and should work as
long as you start the program as described above. If this does not work, pleasedownload TCL
(8.0.5.) from ftp://www.scriptics.com /pub /tcl /tc l8_0 /tcl 8.0 .5.t ar.g z and TK (8.0.5)
from ftp://www.scriptics.com/ pub/ tcl /tcl 8_0/ tk8 .0.5 .tar .gz , and install both packageson
your computer.

3 Getting started

Type ./2dt to start the program. This openstwo windows, the Viewer and Controls windows.
Usethe File ! Open Collection item of the Controls window and selecta �le from the tilings
directory . The �rst tiling (of many) will appear in the Viewer window. Usethe Tilings menu
to navigate through the �le. (Alternativ ely, you can pressthe space-baror 'b'-k ey to move forward
or backward in the �le.) Use the items in the Edit and Layout menus to modify the appearance
of tilings. Alternativ ely, to reshape tilings, press the 'a'-key while in the Viewer window. This
will select and highlight all movable vertices and movable edgecenters. Click and drag these to
reshape. Use the Modify ! Mutate item to modify the symmetry group of a tiling. Modi�ed
tilings can be saved in their current state using the File ! Save item.

4 Mathematical background

The program is basedon \combinatorial tiling theory". In this approach, due to Andreas Dress,
each tiling is encoded in terms of its Delaney-Dresssymbol , which is essentially a �nite, connected,
edge-coloredand vertex-labeled graph that precisely captures the topology and symmetries of a
tiling . The input �les of the program consistof systematically enumerated symbols. The program
reads a symbol from the input �le, constructs a fundamental domain for the tiling, computes
generators for the symmetry group and then applies theseto the fundamental domain to obtain
the whole tiling. Seethe referencesfor more details.

5 Windo ws

The program has two main windows, the Viewer window and the Controls window. All
drawing takesplace in the Viewer window, whereasall user menus are contained in the Controls
window.

(The reasonwhy the menus are not attached to the Viewer window is that the Windowis imple-
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mented using OpenGL, whereasthe user menus are written in tcl-tk and when the program was
written it was not possibleto attach a tcl-tk menu bar to an OpenGLwindow).

By selectingthe Modify ! Mutate menu item, the user can open an additional Mutate window.
For a symmetry group containing rotations or dihedral symmetries , this windows allows
modi�cation of the rotational orders and thus of the symmetry group of the displayed tiling.

All menus are tear-o� menus and this can also be consideredas individual windows.

6 Files

The program works with four typesof �les:

Files ending on .tgs contain a collection of symbols, one for each tiling, and no additional
information. These�les are openedusing the File ! Open Collection menu item.

Files ending on .2dt each contain preciselyone modi�e d tiling , that is, a tiling and additional
information including all modi�cations interactively made by the user. The �les are openedusing
the File ! Open menu item.

Files ending on .2tc contain a color palette which is used to color tilings. These �les are opened
and saved using the Tile Colors ! Open and Tile Colors ! Save in the Tile Colors submenu
of the Edit menu.

Additionally , the menu item File ! Create PS producesa .ps �le containing a postscript picture
of the current tiling.

7 Men us

Note that all menus can be torn-o� (openedas a separatewindow) by selectingthe dotted line at
the top of the menu. In the following we discusseach menu and the menu items it contains.

7.1 File menu

The File menu of the Controls window contains the following menu items:

� The File ! NewWindow item starts a secondcopy of the program, but only works if the
program is called 2dt and is in your path.

� The File ! Open item opensa modi�ed tiling , �le endson .2dt .

� The File ! Open Collection item opensa collection of tilings, �le endson .tgs .

4



� The File ! Save item saves the current tiling in its current state as a modi�ed tiling to
a �le ending on .2dt .

� The File ! Export PS item producesa postscript picture of the current tiling and exports
it to a �le.

� The File ! To Geomview items saves the current tiling in Geomview format.

� The File ! Commandsitem openthe command-lineinterfaceto the program. Unfortunately,
the commandsare currently undocumented. One is of particular interest: dim 2 or dim 3
changethe dimension of the spacein which the tiling is draw. For example,usedim 2 to see
the stereographicprojection of a spherical tiling or usedim 3 to seethe hyperboloid picture
of a hyperbolic tiling.

� The File ! Quit item terminates the program.

7.2 Edit menu

The Edit menu contains the following commands:

� The Edit ! Undo item is not implemented.

� The Edit ! Cut item is not implemented.

� The Edit ! Copy to XFig item copiesthe current tiling to the paste bu�er of the xFig
program.. For this to work, you must have pstoedit installed (freely obtainable on the web).

� The Edit ! Paste item is not implemented

� The Edit ! Line Select item contains a submenu that allows you to select all , select
all visible or select all invisible lines, or to deselect all lines. A line is invisible
if you have given it width none. A selectededgeis highlighted in red.

� The Edit ! Line Width item is used to set the line width of all currently selectededges
to the selectednumber, or to none.

� The Edit ! Straighten item pulls all selected,or all edges,straight. If Always is on, then
the program will alway straighten a tiling when �rst drawing it.

� The Edit ! Tile Colors submenu contains a number of di�eren t items. The Tile
Colors ! Show item togglesbetweendisplaying colors or not. The Tile Colors ! Color
item sets to color mode, the Tile Colors ! Black & White item sets to black and

white mode, and the Tile Colors ! Random item selectsnew random colors. The Tile
Colors ! Open and Tile Colors ! Save items are usedto open or save a color palette
(a .2tc �le).
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7.3 Tilings menu

The Tilings menu is usedto move through a collection of tilings:

� The Tilings ! Next item moves to next tiling in �le.

� The Tilings ! First item movesto �rst tiling in �le.

� The Tilings ! Previous item moves to previous tiling in �le.

� The Tilings ! Last item moves to last tiling in �le.

� The Tilings ! Search item is not implemented.

7.4 Layout menu

The Layout menu controls layout-related aspects of the program:

� The Layout ! ShowF. Domain items highlight the fundamental domain.

� The Layout ! ShowChambers item shows the chamber system .

The next three items determine the drag mode , which determines the e�ect of dragging the
mousein the Viewer window:

� The Layout ! Zoommode item switches to zoom mode .

� The Layout ! Rotate mode item switches to rotate mode .

� The Layout ! Translate item switches to translate mode .

The next two items e�ect only hyperbolic tilings:

� The Layout ! ShowMore Tiles item draws twice as many tiles.

� The Layout ! ShowLess Tiles item draws half as many tiles.

� The Layout ! Reset Layout item reverts to the default layout.

7.5 Mo dify menu

The Modify menu contains items that can be used to alter the current tiling (and the corre-
sponding Delaney-Dresssymbol):
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� The Modify ! Mutate item opensthe Mutate window.

� The Modify ! Dualize item is usedto switch to the dual tiling .

� The Modify ! Max Symmetry item shows the tiling with maximal symmetry .

� The Modify ! Orientate item can beusedto remove all orientation reversingsymmetries
from the symmetry group, if present.

The next three items determine the modi�c ation mode e�ect of the program, that is, what
happenswhen the mouseis clicked on a selectededgeor selectedvertex:

� The Modify ! Reshape mode item selectsthe reshape mode in which vertices and edge
centers can be draggedand repositioned.

� The Modify ! Truncate Vertex Mode item selectsthe truncate vertex mode in which
clicking a selectedvertex will truncate that vertex.

� The Modify ! Contract Edge Mode item selects the contract edge mode in which
clicking a selectededgewill contract that edge(if possible).

7.6 Help menu

The Help menu only contains one item:

� The Help! About item reports the version number.

8 Mouse in teraction

Dragging the mousein the Viewer window will either zoom, rotate or translate the current tiling,
depending on the current mode, see

Clicking on an edgeor vertex will select it, if it was unselectedand is selectable. If it is selected,
it will either allow reshaping by dragging, it will truncate a vertex or it will contract an edge,
depending on the modi�cation mode.

9 Keyb oard shortcuts

In the Controller window, the menus can be navigated using Alt-key short cuts, using the
underlined letters in the menus. The Viewer window recognizesthe following keyboard short cuts:
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� spacebar-key : move to next tiling

� 'a'-key : selectall edges

� 'b'-key : move to previous tiling

� 'B'-key : show/hide chamber system(barycentric subdivision)

� 'c'-key : show/hide colors

� 'C'-key : changemodi�cation mode to contract edgemode

� 'd'-key : randomly changecolors

� 'D'-key : dualize

� 'f'-key : show/hide fundamental domain

� 'G'-key : save tiling in Geomviewformat

� 'h'-key : color in black and white (\heaven and hell mode")

� 'I'-key : command-line interface: read command from stdin

� 'l'-key : draw lesstiles (hyperbolic case)

� 'm'-key : draw more tiles (hyperbolic case)

� 'o'-key : reset layout

� 'O'-key : orientate tiling (if possible)

� 'Q'-key : quit

� 'r'-key : change drag mode to rotate mode

� 'R'-key : changemodi�cation mode to reshape mode

� 's'-key : straighten all edges

� 't'-key : changedrag mode to translate mode

� 'T'-key : changemodi�cation mode to truncate vertex Mode

� 'x'-key : compute tiling with maximal symmetry

� 'z'-key : changedrag mode to zoom mode

� '['-key : move to �rst tiling in �le

� ']'-key : move to last tiling in �le

� '<'-key : move to previous tiling in �le

� '>'-key : move to next tiling in �le

� '0'-key to '9'-key : changewidth of selectededgesto this number
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10 Bugs and unusual features

- Before showing a tiling, the program computesan internal display list of all objects. If you have
zoomeda Euclidean tiling to a very small sizeor have requestedthat the program shows very many
hyperbolic ones, then it might take minutes before the picture appears. Unfortunately, there is
currently no mechanism in place to interrupt this without killing the program.

- The program can not display any spherical tiling with trivial symmetry group.

- Rendering of spherical tilings is very poor. For nice pictures of them, usethe Geomview.

- Many others
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